温馨提示:网站使用自适应技术,手机与电脑显示界面不同,电脑界面显示效果更佳。

做了个小站,积累一些技术,分享一些原创
    体会生活,记录一些小随笔,闲说心得

phpMyAdmin配置文件现在需要一个短语密码及配置文件中的密文(blowfish_secret)太短问题解决方法

原创:张荣国, 新安装或升级phpmyadmin后,出现了警告:

配置文件现在需要一个短语密码

那么这个就是:phpmyadmin的配置文件config中blowfish_secret缺少设置短密码,因为blowfish_secret用一个任意字符串作为cookie的加密字符串,如果因为留空没有加密钥匙,就会出现提示这警告,所以,我们只要给它随便输入一长串字符作为加密字符串就可以了。

首行,在phpmyadmin安装目录找到config.inc.php文件(如果没有,查找config.sample.inc.php这个文件,复制一份到安装根目录,并改名为config.inc.php就可以)

然后,用编辑器打开config.inc.php,搜索:$cfg[‘blowfish_secret’] = ”; 然后再在'中间填入一长串字符,这样就可以了,然后再刷新phpmyadmin的首页,就能看到警告没了。如果还有,再试一下重启iis或Apache。

如果首页这里提示警告:

配置文件中的密文(blowfish_secret)太短

那么就是你刚才填的字符串太短还不够,再加一些字符串进去就可以了。

点击数:473

你可能也喜欢下面相关文章:

发表评论

您的电子邮箱地址不会被公开。

如果涉及回复可见内容,请务必保留下面勾选保存浏览器,才能回复后你可见,否则无效

*

code